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Introduction 
 
3D design is a strange world for most people, and it's difficult to begin in this beautiful world. 
This is because the bet 3D design programs like 3D studio Max cost a lot of money and they 
are very complicated to use.  
Nevertheless, there are some free 3D design programs like ZModeler. With this wonderful 
program we can make an endless number of things designing 3D objects.  
 
ZModeler is an independent 3D editor, that creates objects to Direct3D based games (like 
GrandPrix 4). So we can make cars for this nice game. Another important thing is that ZModeler 
is a low polygon design program, therefore we can make nice objects with few polygons. 
Moreover we can export an import objects for other 3D programs like 3D studio Max.  
 
In this tutorial I try to explain the essential steps to modify an original gp4 car and we will see 
that the result is good. You should read the ZModeler user guide to be familiar with the 
program. I'm not a designer so some steps could be done in a more easy way. If you know how 
to improve the tutorial please tell me in order to update the tutorial and improve it. 
 
Finally, my intention is to make a guide that explains the process of modifying a car:  

• get it out from the game  
• edit it with ZModeler  
• create a new textures using Photoshop or the Gimp  
• finally, get the car and the textures in the game  

 
Whit some practice modelling in ZModeler, I'm sure that you will become in a great 3D designer. 
 
Please e-mail me to make suggestions to improve this tutorial.  
vtemarticent AT hotmail DOT com  
 
 
And remember to visit my home page (http://www4.uji.es/~al063357) because the latest 
updates will be on this page 
 
Moreover for Spanish people I’m working on the translation of the tutorial to Spanish. You can 
find the Spanish version on the web in a few time. 
 
Enjoy designing F1 cars.  
 
 
 
------------------------------------------------------------------------------------------------  
Vicente Martí (Castellón, Spain) 
 
Vicente Martí home page ( http://www4.uji.es/~al063357 ) 
 
 
 

Copyright © 
You haven’t permission to reproduce any part of this tutorial and use it as a base of your 

own work. 
If you want to add a copy of the tutorial on your website, please tell it to me and put my 

name and web page on the download. 
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Contents 
 
In this tutorial I try to explain the essential steps to modify an original gp4 car.  
The parts of this tutorial are:  

• ZModeler basics.  
o Introduction  
o Working with the views  
o Objects box  
o Status bar  
o The axis  
o The material editor  
o Modes  
o Snapping tools  
o Other important tools  
o Numeric Bar #1  
o Create  
o Modify  
o Surface  
o Select  
o Display  
o The gp4 filter  

• How to create a good mesh  
o What we need?  
o Get car out GP4  
o Objects in the car  
o The photos  
o Creating the 3D mesh  
o Some tips  

• Adjust the normals  
o What is a normal?  
o A slightly bended surface  
o A very bended surface  
o The front wing of a GP4 car  
o The body of a GP4 car  

• Map the car  
o How to map the car  
o Saving the car1 and car2 (lod_0)  
o The car_lod_4  
o The materials (textures) in a GP4 car  

• Paint the car  
o How to paint the templates.  
o Texture shading  
o Car body lines and screws  
o Logos  
o Paint a cockpit  
o Paint a helmet  
o Paint pitcrews  

• Finaly, get the car and the textures in the game  
o the gp4 files, the lod_0, lod_1, lod_2, lod_3 and lod_4  
o The tex files  
o Make a wad file  
o some adjustments with team editor  
o Modify car phisics with GP4 Phisics Editor  

• Summary: the most important steps  
• The most important links and tutorials  
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ZModeler basics 
Introduction  

 
 
 
ZModeler has the screen divided into 4 parts. You can select within several views in each part: 
Front, Back, Right, Left, Top, Bottom, UVMapper, User View and 3D view. 
To change the view, right click on the button on the top left in each view and select the desired 
view from the list.  
You can change the size of the views moving the split bars. There is only 1 active view at time 
(blue border) and you can make it full screen by pressing “F” in your keyboard. 
 
In ZModeler the meshes are made by faces. A face has 3 verts that are connected by an edge. 
Contiguous polygons (faces) can share vertices. Each vertex has a normal assigned to it (a 
normal is a green line and it defines how light is reflected).  
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You can make modifications in ZModeler in different levels: vertex, edges, faces and objects. 

To change between these levels you can click on the tool bar or press 1, 2, 3 or 
4 respectively on your keyboard. 
 

This button is to create and modify splines. 
 

These buttons are to open a new blank document, to load an existent z3d 
file, to save the current file ant the last two to import and export a file. 
 
To make modifications at vertex, edges or faces level you must get inside one object. To do this 
first switch to objects level and click on the desired object. Now switch to vertex, edges or faces 
level to make the modifications. 
If you want to make modifications at vertex, edges or faces level in two or more objects, you 
have to select the objects on objects level, activate the SEL mode. After that, switch to the 
desired level (vertex, edges or faces) and click on the selection. Finally you can make the 
modifications in the selected objects (this is very useful to adjust the normals, map…) 
 
An object, face, edge or vertex has 4 states in ZModeler:  

• Active: the object, face, edge or vertex is in color bright blue, the mouse is over it. 
Inactive: the mouse isn’t over it.  

• Hidden: you can’t see the object, face, edge or vertex. 
Unhidden: you can see the object, face, edge or vertex.  

• Selected: the object, face, edge or vertex is in color red. If you put the mouse over the 
selection it becomes active, color bright red. 
Deselect: an object, face, edge or vertex that isn’t selected.  

• Enabled: you can modify the enabled object (all objects are enabled by default). 
Disabled: you cant modify the disabled object, his color is grey (in 3D view the color is 
normal).  

 
 
Working with the views 
You have 9 views in ZModeler and all of them are very useful. You can make modifications in 
one view at time (in the active view), but you can see the modifications in the other views at the 
same time. For example you can move a vertex in front view and see it in 3D view. 
 
To change the view and set up the options of each view (for example enable or disable the 
wireframe, enable flat shading…) click on the small square on the top left in the desired view. 
These options are self-explanatory, so practice with them. 
 
Lets see the most important about the views:  

• Front, back, right, left, top and bottom are very obvious, you see your model in front, 
back, right…  
To zoom in and out use + an – on your keyboard and to pan use the arrows on your 
keyboard.  

• 3D view: you can see your 3D model in 3D with shading, reflections and textures. 
You can’t make any modification in this view. 
To zoom right click and drag, to rotate the 3D model left click and drag. To pan the view 
hold the two buttons of the mouse and drag.  

• User view: it’s like 3D view but you can make modifications to your model.  
To zoom, rotate and pan do the same as in 3D view but holding ALT button on the 
keyboard at the same time you click with the mouse.  
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• UV Mapper: in this view you can see a texture and you will map the surfaces over it. To 
zoom in and out use + an – on your keyboard and to pan use the arrows on your 
keyboard.  

 
 
Moreover you can see the active view full screen by pressing “F” on your keyboard.  
 
Objects Box 
 

 
 
 
In this box are all the objects of your z3d file. To make some modifications to the properties of 
the objects just right click on the desired object an a menu will appear. The most important tools 
in this menu are: Order -> Move Up or Move Down, Create a Copy, Rename and Delete. (all of 
this actions are self-explanatory).  
You can hide an object by click on it in the list and unhide by click on it in this list. 
The 4 buttons of the bottom are very useful: hide all (hides all the objects), show all (shows all 
the objects), select all (selects all the objects), deselect (deselects all the objects). 
 
 
Status Bar 
In this bar is displayed some information about the selected tool. This information is very useful, 
so read it when you select a tool. 
 
For example in the next image you can see the information displayed for the Scale tool:  

 
 

 
 
The axis 
The next picture represents the 3 axes in ZModeler. The origin of the axes is the grey X, this X 
is the center of the axis and can be places anywhere.  
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You can make modifications in two different ways: relative and absolute modification. You can 
change from relative to absolute and vice versa by pressing TAB on your keyboard or click on 
the tool bar.  

• Relative modification  
This is very simple, you can make the modifications within the view that you are 
working: H (horizontal), V (vertical), D (depth).  

o H: you can make modifications in horizontal on the view. (for example move 
from right to left in your view bur no up and down).  

o V: you can make modifications in vertical on the view. (for example move from 
up an down in your view bur no from right to left)  

o H + V: you can make modifications in vertical and horizontally on the view  
o D: you can make modifications in depth on the view  
o X: is the center of the axis.  

You can put the center in any place on the view. To place the center of the axis 
put the mouse in the desired place and press “ . “ on your keyboard or go to 
Display -> Place Axis and click on the desired place with the mouse. 
To reset the axes origin to (0,0,0), go to Display -> Reset Axis. 
The axes center is a reference point to a lot of tools like mirror, rotate, scale … 
These tools work with regard to these point (the center, X).  

 

• Absolute modification  
It’s very useful for the User View.  
The modifications are made in X, Y or Z (not two are the same time). These axes are 
the “global” axes by default, but you can change it (move, rotate…) using the Display -
>Local Axis tools.  
This axes are a little axes that you can see with each object (each object has a local 
axis). The center of this axes is not the X, the center of the local axes is the origin of this 
little axes.  

 
 

The Material Editor  

You can go to the material editor by clicking on the tool bar or you can press “e” in your 
keyboard. The next image is the material editor:  
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By default you have one material: . To add more materials copy the and rename it.  

If you work with TGA files you should keep the alpha parameters unused to avoid problems.  

Finally, you can load textures for your materials. To do this check the Primary Texture box and 
go to Load Map button. Then the image manager will appear, click on Add… button and search 
your image, after that click on OK button. 
To add a texture for the Reflection Map do the same as Primary Texture but check the 
Reflection Map box.  

 
Some tips about the material editor:  

• To map a group of faces first you have to assign a material to the selection. To do this 
select a group of faces, activate SEL mode, go to the material editor, select a material 
(in the list of the existent materials at the top of the material editor). Finally click on the 
Assign to Selection Button and after that the selected material will be assigned to your 
selection. 

• You can reload all the textures by pressing CTRL + R. This is very useful when you are 
painting the car: save the TGA file in your paint program, go to ZModeler and press 
CTRL + R, you will see the modified textures on your 3D car.  

 
 
Modes 

There are three different modes in ZModeler: EXT (extended), SEL (selected) and MUL (multy).  
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We will see an explanation about the modes: 

• EXTended mode works with tools like move, rotate, scale… When you select the EXT 
mode in the menu bar (or when you press the “ , ” key on your keyboard), it will appear 
two circles at the cursor. The small circle will modify elements like normal modification 
but the big circle will modify less the element: the closer the element to the big circle the 
less the modification. Moreover, you can make bigger-smaller outer circle by pressing 
the up-down arrows in the keyboard. And you can make bigger-smaller inner circle by 
pressing the right-left arrows in the keyboard.  

• SELected mode mode forces ZModeler to work with selected elements, it’s to say, you 
have to select elements: objects, faces, edges or vertices and when you apply a 
modification it will be applied to the selected elements. 
You can activate the SEL mode by pressing the SEL button on the menu bar or press 
the SPACEBAR on the keyboard.  

• MULty mode works with some tools like move, rotate, select… For example if you want 
to move or select two vertices that are close in the view, switch on the MUL button on 
the menubar or hit the “ / ” key on your keyboard and select the desired tool: move, 
select… After that, put the mouse over the close vertices and you will see that the two 
vertices are active (color bright blue), finally when you click and drag the two vertices 
will move (if you have selected the move tool) or the two vertices will be selected (if you 
have selected the select tool),  

 
 
Snapping Tools 

Snapping is when you move something (an object, vertex, face…) with the mouse an then it is 
automatically magnetically attracted to a spline, vertex, edger or gird. 
 
Let’s see all the options (you can select several options at time, for example vertex and grid line 
snapping tools.):  

• Spline Snapping tool. 
When you drag something with the mouse, it snaps to the nearest spline vertex.  

• Vertex Snapping tool. 
When you drag something with the mouse it snaps to the nearest vertex.  

• Edge Snapping tool. 
When you drag something with the mouse it snaps to the nearest edge.  

• Grid Snapping tool. 
When you drag something with the mouse it snaps to the nearest view grid-line.  

• 2D / 3D Snapping toggle switch. 
If you press this button you will activate the 3D mode. In 3D mode when you drag 
something with the mouse it will snap to the nearest spline vertex, vertex or edge 
(depending of the snapping toll that you are using) in the 3 dimensions. 
For example if you drag a vertex in vertex snapping tool and 3D mode, the vertex will 
snap with the nearest vertex in 3 dimensions but if you have activated the 2D mode, it 
only will snap in 2 dimensions (the dimensions of the current view).  
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• No Depht Snapping mode toggle. 
If you don’t press this button, when you snap something ZModeler will consider 3 
dimensions on the vertex, edge… that you are moving and the vertex, edge… that you 
want to snap with.  
If you press this button ZModeler only will consider 2 dimensions (the dimensions of the 
current view within you are moving the vertex, edge…), it’s to say, the depth is not 
considered.  

You can also use for example the vertex-snapping tool in the User View. In this view when you 
drag a vertex in vertex-snapping tool activated, the vertex that you are moving will snap with the 
other vertex in 3 dimensions. This is very useful to make a contour to two parallel flat surfaces 
with double vertex (see the mesh section: making the font wing).  
 
Other important Tools 

• Selecting tools. 
These buttons allow you to select something with the left mouse button instead the right 
button using the Select -> … commands.  

• Zoom tool. 
Hold ALT and left click to zoom in, fight click to zoom out. If you hold ALT, left-click and 
drag, the rectangle you made will be zoomed in.  
You can also use + and – on the keyboard to zoom in and out. 

• Panning tool. 
Hold ALT, click and drag to pan the view. You can also use the arrows on the keyboard 
to pan the view.  

• Fit to view tool. 
Press this button, hold ALT and left click on an object to zoom it in the whole view or 
right click to fit your selection.  

• Auto Scroller tool. 
Press this button and scroll the view by moving the mouse.  

• Background image control tool. 
Pres this button and: left mouse click and drag to move the background image and right 
mouse click and drag to zoom the image.  

• Predefined create objects tools. 
These tools allow you to create this 3D objects (cube, sphere, cylinder, cone, torus and 
tube). Select the desired object, left click and drag, your 3D object will be created.  

 
 
Numeric Bar #1 
 

 
 
 
This numeric bar is a numerical input for several tools:  
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• Modify -> Rotate: 
You can adjust how many degrees won to rotate.  

• Modify -> Scale: 
You can adjust the % that you want to reduce or enlarge your object, edge…  

• Modify ->Break: 
You can adjust the number of verts that you want to insert when you break an edge.  

• Surfaces -> Normals ->Rotation 
You can adjust how many degrees you want to rotate the normals.  

• Surfaces -> Normals ->Projection 
You can adjust the % of projection that will be applied.  

• Create -> Splines -> NGon 
You can adjust the number of sides of the ngon.  

 
 
Create 
 
 
First of all you have to create an object because you can’t create a single face. Moreover, none 
of the create tools are axis dependant and all of them work with left click.  
The most interesting are:  

• Create -> Surfaces 
o Create -> Surfaces -> Flat 

To create a new object with a flat surface: select this tool, left click and drag a 
rectangle. Type the number of horizontal and vertical steps and the name of the 
new object in the box that will appear.  

 

• Create -> Objects 
o Create -> Objects -> Copy 

You can copy objects with this tool. You can copy a single object or several 
selected objects. The result is one object. Select his tool, switch to objects 
level, left click on the object or the selected objects and type the name of the 
new object in the box that will appear.  

o Create -> Objects -> Detach 
You can make a new object from one face or several selected faces. Select this 
tool, left click on the selected faces and type the name of the new object (it 
works on faces level).  

o Create -> Objects -> Unite Select 
You can unite objects and vertices. On objects level, select the objects that you 
want to unite, select the Unite Select tool and left click. Finally type the name of 
the new object. 
On vertex level, select two or more vertices and do the same as on objects, the 
result is one vertex. Hold CTRL for moving vertices into single point without 
uniting the vertices.  

o Create -> Objects -> By Material -> Split 
Apply this tool to selected objects to split them by material to multiple sub-
objects.  
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• Create -> Faces 
The Create -> Faces tools work on vertex level. You must add faces to an existent 
object.  

o Create -> Faces -> Single  
This tool creates a single face. You can use an existing vertex (put the mouse 
over a vertex and the vertex will become blue, then left click) or create a new 
vertices to the face. To create the new vertices don’t click over a vertex.  

o Create -> Faces -> Strip  
This tool creates a strip of faces. You can use an existent vertex or create a 
new one. To create a Strip, select this tool, left click to create the first vertex 
and continue clicking to crate the other vertices. The last two vertices for the 
previous face are the two first vertices for the new face and so forth. To stop 
this tool, hold CTRL and left click.  

o Create -> Faces -> Fan  
This tool creates a fan of faces. The first left click creates the center vertex of 
the fan, the other clicks create the vertex (therefore the faces) of the fan with 
regard to the center vertex. To stop this tool, hold CTRL and left click.  

 

• Create -> Spline 
You can create splines with these tools.  

 
 
Modify 
With these tools you can make a lot of modifications. All of them work with left click.  

• Modify -> Extended 
o Modify -> Extended -> Perspective 

Click and drag mouse up/down to change perspective factor.  
o Modify -> Extended -> Bend 

Right click for detailed help. Click and drag the mouse up-down to bend 
geometry (this tool is center and axis dependant)  

 

• Modify -> Align 
o Modify -> Align -> Axis 

Select a group of vertices, activate SEL mode and left click. The selected 
vertices will be aligned to the save value on desired axis (H, V, D or X, Y, Z)  

o Modify -> Align -> Line 
Select a group of vertices, activate SEL mode and left click to create a line 
based on vertices. Finally hold CTRL and click to align the selected vertices to 
the line.  

o Modify -> Align -> Plane 
Select a group of vertices, activate SEL mode and left click to create a plane 
based on vertices. . Finally hold CTRL and click to align the selected vertices to 
the plane.  

o Modify -> Align -> View 
Select a group of vertices, activate SEL mode and left click to align the selected 
vertices to the plane of view.  

 

• Modify -> Move 
You can move a single or some selected (in SEL mode) vertices, edges, objects and 
splines along your selected axis (H, V, D or X, Y, Z).  
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• Modify -> Rotate 
You can rotate a single or several selected vertices, edges, objects and splines around 
the axis center (X).  
To rotate a specific number of degrees put the number of degrees in the numeric box 
#1. This tool depends on the axis (H, V, D or X, Y, Z).  

• Modify -> Scale 
You can scale vertices, edges and objects. This tool depends on the axis (H, V, D or X, 
Y, Z). and the axis center (X). The element or elements are scaled with regard to the 
axis center (X) and the axis mode (H, V, D or X, Y, Z).  
You can specify the % that you want to reduce or enlarge your element in numeric box 
#1.  
To 3D scale hold SHIFT.  

• Modify -> Mirror 
You an flip vertices, edges and objects. The modification is made with regard to the axis 
center (X) and the axis mode (H, V, D or X, Y, Z).  
After mirroring an object you must reorient it because after mirroring the object is inside-
out. You need flip the normals also.  

• Modify -> Break 
You can break a vertex or several selected vertices (this tool works on SEL and MUL 
mode). When you break a vertex, new vertices are created (one for each face).  
 
You can break an edge ( it doesn’t work with SEL, EXT and MUL mode) and a new 
vertex is created in the middle of the edge therefore two faces are created (You can add 
more vertex using the numeric box #1).  
 
You can break a face or some selected faces (this tool works on SEL and MUL mode). 
A vertex is created in the center of the face and therefore three faces are created.  

• Modify -> Reorient 
You can reorient edges, faces and objects. Reorient tool flips the faces inside-out in 
faces and objects level. In Edges level reorient tool changes direction of the edge inside 
quad to the opposite (you have to apply this tool only one edge at time). 
If you hold CTRL while clicking you will flip the normals.  

• Modify -> Delete 
You can delete vertices, edges, faces, objects and splines. When you delete something 
in an object, ZModeler deletes the unused vertices that are connected to the vertices 
that you have deleted, if you don’t want to delete the unused vertices hold CTRL while 
clicking.  

 
 
Surface 
With these tools you can make map your car and modify the normals. All of them work with left 
click.  

• Surface -> Mapping 
You can make some modifications to the UV mapping of your 3D model. Remember to 
assign a material to your faces before assign UV mapping.  

o Surface -> Mapping -> Assign UV 
With this tool you can assign the mapping at your 3D model. It depens on the 
view (left, top, front…) that you have clicked over your selected faces.  
If your face or faces are already mapped, when you apply this tool in the UV 
view you will see the UV mapping of these faces. I mean that mapped faces are 
not remapped if you apply a second time the Assign UV tool.  
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o Surface -> Mapping -> Reset UV 
This tool deletes the UV mapping of the selected faces. This is useful when you 
want to remap a group of faces: select the desired faces, reset the current UV 
mapping and assign a new UV mapping.  

o Surface -> Mapping -> Flip UV 
This tool flips your UV mapping  

o Surface -> Mapping -> Rotate UV 
This tool rotates your UV mapping.  

 

• Surface -> Normals 
You can make a lot of fine adjustments to the normals of your model. Remember that to 
see the effect of the normals on your car you have to switch off the flat shading and to 
see the reflections (environment mapping) you have to load a reflection map. 
You can see a good explanation of these tools in the ZModeler tutorial: Creating cars 
from scratch.  

o Surface -> Normals -> Bound Gismo 
Right click for detailed help about his tool in ZModeler.  

o Surface -> Normals -> Rotate 
Rotates the normals.  

o Surface -> Normals -> Scaeling 
This tool scales the normal length. The shorter the normal the less the 
brightness.  

o Surface -> Normals -> Flip 
This tool flips normal direction. Hold CTRL for non 3D flipping.  

o Surface -> Normals -> Calculate 
This tool calculates the normals.  

o Surface -> Normals -> Projection 
This tools projects the normals from axis center (X). You can adjust the % of 
projection in the numeric bar #1.  
Hold CTRL for parallel and SHIFT for 3D projection.  

o Surface -> Normals -> By Gismo 
This tool projects the normals but the center is the nearest vertex of an object 
(the gismo object).  

 
 
Select 
Remember that some tools like move, scale... work with selected elements and you have to 
switch on the SEL mode.  
You can select objects, faces, edges and vertices. All the select tools work with right click.  

• Select -> Single 
You can select faces, edges, vertices and objects one by one by right click. To deselect 
a selected element right click on the desired element.  

• Select -> Quadr 
To select right click and drag, a rectangle will appear. To extend the selection hold 
SHIFT and select a new group of elements. To deselect a part of your selection hold 
CTRL right click and drag.  

• Select -> Circle 
The same as QUADR but the shape is an ellipse.  

• Select -> Separated 
It works on faces and vertex level only. 
On vertex level this tool selects the vertex your mouse is over and all the vertices 
connected by and edge. 
On faces level, this tool selects all the connected faces by an edge. 
Hold CTRL to deselect.  
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• Select -> All 
Selects all the objects on objects level, all the faces on faces level and all the vertices 
on vertex level.  
This tool selects only the visible elements.  

• Select -> None 
Deselects all the objects on objects level, all the faces on faces level and all the vertices 
on vertex level.  

• Select -> Invert 
Inverts the selection. Everything selected becomes deselected and everything no 
selected will be selected.  

• Select -> By material 
This tool selects the faces that belong to a certain material (you can select the desired 
material from a bow that will appear after right click). 
This tool doesn’t clear the previous selection, it just adds the faces of the desired 
material to the previous selection. 
Hold CTRL to deselect.  

 
 
NOTE: You can select right click tools (select tools) and left click tools at the same time. 
For example you can select at the same time Select -> Single and Create -> Objects -> Unite 
Select. With right click you can select objects for example, and with left click you can unite the 
selection.  
 

•  Display -> Reset Axis 
This tool places the axis center to the origin (0,0,0). Moreover this tool doesn’t deactivate any 
other left click or right click tools that you have activated before reset the axis.  
•  Display -> Center Axis 
Centers local axis (X, Y, Z axis) of the object.  
•  Display -> Local Axis 

• Display -> Local Axis -> Copy 
Click on source object and then on the destination object. Local axis will be copied.  

• Display -> Local Axis -> Move 
Moves local axis of the object. Click on object and drag the mouse to move axis.  

• Display -> Local Axis -> Rotate 
Rotates local axis of the object. Click on object and drag the mouse to rotate axis.  

• Display -> Local Axis -> Flip 
Flips local axis direction. Can be applied on X, Y or Z mode only.  

• Display -> Local Axis -> Reset 
Resets axis position and orientation  

 
 
The grand prix 4 filter 
 
You can import gp4 files with this filter but if the gp4 file is locked open it with 3D editor or GP$ 
genius and save it. Now you can import it in ZModeler. 
Moreover you can export gp4 files and they are locked. If you want to export a gp4 file without 
locking, write the extension with uppercase letters in export dialog box. For example: 
car_minardi_car1_lod_0.GP4  
You can’t import locked files directly, so you have to save your work (model) in z3d files in order 
to open your model with ZModeler in a easy way.  
GP4 is very sensitive to objects name, the names of the objects are case sensitive and you 
must keep the names in order. 
GP4 filter doesn’t support untextured polygons, so you have to map all the faces and load all 
the textures before exporting.  
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Some useful ZModeler hotkeys: 

ZModeler hotkeys are very useful to make faster the proces of modelling. To set up the hotketys 
read the explanation above the table and make sure that the ACTIVE button and Enabled is 
switched on. 
Moreover there is one important restriction on Hot Keys: 
Hotkey combination can only be accepted when NON-3D view is active and mouse cursor is 
inside the view.  

Files Accelerators 
Ctrl + N Clears the scene and creates a new one 
Ctrl + O Opens the scene and replaces current scene 
Ctrl + S Saves the scene 
Ctrl + I Imports 3D files and merges with current scene 
Ctrl + E Exports current scene 
Alt + X Quit the program 
Rendering options and view options 
Q Flat shading 
A High chrome 
B Chrome 
S Solid 
W Wire frame 
Ctrl + T Use textures 
Ctrl + R Reload all textures 
P Camera perspectived 
Alt + R Reset Camera settings 
Shift + R Reset Camera position 
G Mini Gird 
Alt + G Normal Gird 
I Load Background Image 
Alt + I Show background Image 
F6, Shift + F6 Switches active view 
Arrow keys Scrolls the active view 
+, - Zoom in and out 
Ctrl + Shift Creates self-test object Z letter 
Select 
Shift + G Select quadr (selects tool only) 
Shift + A Select All (performs) 
Shift + I Select Invert (performs) 
Shift + S Select Single (selects tool only) 
Shift + D Select None (performs) 
Normals 
C Surface/Normals/Calculate (performs) 
Axis and modes 
TAB, Shift TAB Switches current edit axis (H, V, D or X, Y, Z) 
“ . ” Places axis center at the cursor 
SpaceBar Switches Selected mode on/off 
“, “ Switches extended mode on/off 
“ / “ Switches multy mode on/off 
1 Switches to Verices level 
2 Switches to Edges level 
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3 Switches to Faces level 
4 Switches to Objects level 
“ ´ ” Switches Splines mode on/off 
CTRL + Arrow keys Jumps marking from vertex to vertex (or frum face to face) 
Backspace Temporary switches to objects level for selecting another object for 

modifications. 
Enter Alternate to pressing the left mouse button 
Editing accelerators 
Supr (Del) Modify/Delete (performs) 
Insert (Inst) Modify/Break (performs) 
R Modify/Reorient (performs) 
Alt + M Modify/Move (select tool only) 
U Create/Objects/Unite Select (performs) 
Alt + S Create/Faces/Strip (selects tool only) 
Alt + F Create/Objects/Flat (selects tool only) 
H Display/Hide (performs) 
Alt + A Display/Unhide (performs) 
Float Bars and dialog boxes 
Ctrl + 1 Show/Hide objects float bar 
F1 About ZModeler 
Ctrl + A Attributes box 
E Material editor 
 
 
Moreover we can add some new hotkeys for all the tools of ZModeler. In order to do it, go to 
Plugins -> Hot Keys.  

 
 
 
Then a dialog box will appear:  
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Finally select the desired tool and go to the Hot Key section (right bottom) and select Enabled, 
Then set up the hot key (Custom1 + Custom 2 + Key).  
 
For example I have set up for the tool Create -> Faces ->Single the hot key Alt + Z (note that by 
default these tools haven’t assigned any hotkey). 
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The mesh 
 
What we need to make the car?  
 
We need some photos of the car and an original GP4 car (the lod_0 and the lod_4). 
There are some photos of the R23 (I'm going to explain how to make the front wing): 

 
Top view  

Right view  Front view  

 
 
To modify the original gp4 car first you need to extract it from the cars.wad, to do this you can 
use gp4-master (you can download it in www.grandprixgames.org). or WadUpdater (you can 
download it in www.realgpx.com).  
A wad file is something like a zip file, it's to say both are compressed files that contains a lot of 
small files. This allows to reduce the time to charge the game in the memory of the PC and the 
game is faster.  
 
I will explain how to extract the car of cars.wad using WadUpdater: 

 

 
 
Select your cars.wad in WadUpdater, then click on ExtractWad button. Type the name of the 
folder in wich the files of your cars.wad will be extracted (for example: cars) and click on OK. 
All files of your cars.wad will be extracted in this folder. 
Now you have to search the gp4 files that we need (car_myteam_car1_lod_0.gp4 and 
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car_myteam_car1_lod_4.gp4 files)  
 
Then, open ZModeler and import the gp4 file (the car_myteam_car1_lod_0.gp4 file) save it as 
car1.z3d (this is the file that we are going to modify.  
Import the gp4 file (the car_myteam_car1_lod_4.gp4 file) save it as car_lod_4.z3d. 
 
If the gp4 shape is locked you can't import it directly in ZModeler. In order to can import it in 
ZModeler, open the gp4 shape whit GP4 genius (you can download it in 
www.grandprixgames.org) or 3Deditor (you can download it in www.realgpx.com), then save it 
and the shape will be unlocked. Now you can import the gp4 shape in ZModeler. 
 
We are going to modify some parts of the original gp4 car because is very difficult to make one 
from the scratch. 
 
 
Objects in the gp4 car  
 
You should know that all the cars in GP4 have the wheels at the same position, so we can't 
move the original position of the suspensions and the brake disk because if we move the 
suspensions the wheels will be in an incorrect position. 
We can modify the cockpit because we can adjust the position of the helmet and the steering 
wheel with Team Editor (it is explained at the end of this tutorial in the get the car in game 
section). 
Moreover you can modify the position of all the other objects of the car. 
 
The order of the objects in a gp4 car is very important, and you must have all the objects in 
following order: 
 
objects in car_myteam_car1_lod_0.gp4  

1. cockpit  
2. engine  
3. f_l_brakeglow  
4. f_r_brakeglow  
5. left_barge_board  
6. left_front_fin  
7. left_front_suspension  
8. left_front_wing  
9. left_rear_fin  
10. left_rear_suspension  
11. left_sidepod  
12. lower_rear_wing  
13. nose_cone  
14. r_l_brakeglow  
15. r_r_brakeglow  
16. rear_light_on  
17. right_barge_board  
18. right_front_fin  
19. right_front_suspension  
20. right_front_wing  
21. right_rear_fin  
22. right_rear_suspension  
23. right_sidepod  
24. upper_rear_wing  
25. z_cockpit_insert  
26. z_cockpit_left_mirror  
27. z_cockpit_right_mirror  
28. z_cockpit_visor  
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A gp4 car has 5 lods (you can see it in the cars.wad). These lods are:  

• car_myteam_car1_lod_0.gp4  
• car_myteam_car1_lod_1.gp4  
• car_myteam_car1_lod_2.gp4  
• car_myteam_car1_lod_3.gp4  
• car_myteam_car1_lod_4.gp4  

 
The lod_0 is the most detailed shape and it's used when you see the car in a short distance. 
And the lod_4 is the less detailed shape and you can see it in the mirrors for example. 
The objects for the other lods are:  
 
objects in car_myteam_car1_lod_1.gp4 
car_myteam_car1_lod_2.gp4 
car_myteam_car1_lod_3.gp4 

1. cockpit  
2. engine  
3. f_l_brakeglow  
4. f_r_brakeglow  
5. left_barge_board  
6. left_front_fin  
7. left_front_suspension  
8. left_front_wing  
9. left_rear_fin  
10. left_rear_suspension  
11. left_sidepod  
12. lower_rear_wing  
13. nose_cone  
14. r_l_brakeglow  
15. r_r_brakeglow  
16. rear_light_on  
17. right_barge_board  
18. right_front_fin  
19. right_front_suspension  
20. right_front_wing  
21. right_rear_fin  
22. right_rear_suspension  
23. right_sidepod  
24. upper_rear_wing  

 
objects in car_myteam_car1_lod_4.gp4  

1. cockpit_low  

We will edit the lod_0 and when we finish it, we will delete the z-objects(z_cockpit_insert, 
z_cockpit_left_mirror,z_cockpit_right_mirror, z_cockpit_visor) and then save as lod_1, lod_2 
and lod_3. 
Finally we won't edit the lod_4, we only will remap it (to see the correct colors of the car in the 
mirrors).  
 
 
To finis this section I'm going to tell you a good trick to save time in ordering the objects in a gp4 
car. 
To order the objects names of our car in a easy way: 
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Type the objects name in ZModeler (all the objects but not in alphabetical order). 
 
Now export the car in .gp4 format. 
 
Load the exported car in 3Deditor ( www.realgpx.com). 
Then go to Action -> Sort car objects and the objects will be ordered in alphabetical order 
automatically). 

 
 
Save this file. 
 
Finally import the saved gp4 file in ZModeler and you will see that the objects are in alphabetical 
order. 
 
This method saves a lot of time ordering the objects in ZModeler. It's really good. 
 
Thanks Dahie to tell it to me. 
 
 
 
The photos  
 
We need some photos of the parts of the car that we are going to modify, for example the front 
wing. 
There are some photos of the R23 (I'm going to explain how to made the front wing): 
 
We need a photo from a top wiew, other from the side and other from the front. 
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Top view  

Right view  Front view  

 
You have to save this photos in BMP format in order to can import it in ZModeler (if you want 
you can save it as TGA or PNG format). 
These images must be squared and the dimensions must be: 256, 512, 1024 or 2048 pixels. I 
mean 256x256, 256x512, 512x512, 512x1024 ...  
 
To do this open the photo of the car with your favorite paint program (The gimp, adobe 
Photoshop, paint shop pro...) and then change the canvas size of the image (round up the size 
of the image to the nearest available dimensions 256, 512, 1024 or 2048 pixels) and keep the 
image centered. Finally save it as BMP, TGA or PNG. 
 
Now, in ZModeler you can load the image using the menu at the top-left corner of the view, then 
right click over the small rectangle and in popup menu choose: Background -> Image -> Load 
Image, then you will see the textures browser. Press Add... and search your image (the BMP, 
TGA or PNG) and click OK. 
You have the image in the background. You can modify the background image with the image 

background control . Press this button and then with left click and drag with the mouse you 
can move the image and with right click and drag you can scale it. 
 
You can see this in the following image (made with adobe Photoshop):  
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Move the image and place it under the nose cone and the front wing of the original gp4 car. 
(How to import the car is explained in the next step: creating the mesh)  

 
 
 
Now we can go to the next step. 
 
 
 

Building a GP4 car tutorial  Vicente Martí Centelles 



Building a GP4 car tutorial        |      http://www4.uji.es/~al063357        |        Vicente Martí |        26 

Creating the 3D mesh  
 
First of all we have to import the gp4 car, to do this go to file -> import. 
Import the lod_0 and save as car1.z3d. 
Import the lod_4 and save as car_lod_4.z3d.  
You can see the difference of detail (the number of polygons) in the following image:  

 
 
 
Now, we have to set up ZModeler: switch of the normals automatic update and extended mode 
and select flat shading.  

and 

 
 
 
We only are going to create one part of the wing, for example the left. 

Building a GP4 car tutorial  Vicente Martí Centelles 



Building a GP4 car tutorial        |      http://www4.uji.es/~al063357        |        Vicente Martí |        27 

 
First of all hide all the objects. Then we will create a flat surface on the top wiew. To do this 
choose Create -> Surface -> Flat. Right click and drag (make a rectangle over one of the wings 
in the front wing). Then type 0 horizontal steps and 6 vertical steps and the name of the wing, 
for example wing1. You will see the flat surface over your photo.  

 
 
 
Now switch to vertices level and adjust the flat surface to the photo (top view):  

 
 
 
And with the gird snapper , snapp the vertex near to the center to the gird,it makes that 
when you move something with the mouse it will snap to the nearest line gird. (This is to make 
that the other part of the wing fit perfectly when we make it by mirroring this part of the front 
wing) 
Adjust the flat surface to the photo on the front view:  
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Copy the flat surface (wing1) and name it as wing2. Reorient this object in objects level and 
move it down in the front view in the vertical ,[V], direction (in this way we can only move up and 
down the wing2. 
 
 

 
 
 
Select these two objects, wing1 and wing2 (in objects level) and go to Create -> Objects -> 
Unite Select, then click anywhere and type the name of the new object in the box that will 
appear, for example wing, and the new object is made. 
 
The next step is to make the contour of these surfaces. In order to do these switch to vertex 
level and go to Create -> Faces -> Strip. In the front view make a surface like in the photo (you 
must make the same number of steps to this surface, I mean the same number of vertex, in the 
image it's very clear). To stop, hold CTRL and click:  

 
 
 
Select all the vertex of the surface created, press SEL mode, now move these vertex next to the 
front part of the wing in the top or left view (this is to make the process of snapp the vertex 
easier). 
 

Now press the vertex snapper button , (it makes that when you move something with the 
mouse it will snap to the nearest vertex). 
Select Modify -> Move and move the vertex of the surface to the upper and down surfaces of 
the wing, in the User View, the vertex will snap automatically. Do the same for all the vertex of 
the surface:  
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Now we can calculate the normals. To do this, switch to objects level, and go to Surface -> 
Normals -> Calculate. To see the shading we have to switch off the flat shading. We can see in 
3D view that the shading is correct.  
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Now we have to make the same for all the wing the result is:  

 
 

 
And for the fin:  
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Finally we have the left front wing but we need to cretate the right front wing. We will make a 
copy of the left wing and name as right wing. Now place the axis (X) to the center, in order to do 
this Display -> Reset Axis and the axis will be placed in the origin (X=0, Y=0, Z=0). 
In the front view in Horizontal axis mode [H] and objects level,go to Modify -> Mirror and click on 
the left wing object. The next step is reorient this object: Modify -> Reorient and click on the 
object. Finally you have to flip the normals you can: 

• select Modify -> Reorient hold CTRL and click on the object  
or  

• select Surface -> Normals -> Flip and click on the object  
 
The result is:  
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We have the wireframe of the front wing made. 
 
To finish this chapter of the tutorial I have to tell you that when you made the car body, 
the car body must be in one object. It's important to get a good shading in the car (read 
the shading chapter in this tutorial). 
Then calculate the normals of the car body and make a back up file (when the car is 
finish). Finally detach the car body in the gp4 required objects: cockpit, engine, 
left_front_fin, left_sidepod, nose_cone and right_sidepod. 
Remember to order the objects of the car (see the list) and check hat all the objects are 
in your car.  
 
You can see in the following image that with some modifications on the original car the 
new car is very different.  

 

 

 

 
Some tips to get a good mesh  
 
 

• Try to make a clean mesh, I mean to make a rectangular poly structure. Rectangular 
poly structures have a good set of normals (think on a flat surface created using Create 
-> Surfaces -> Flat, this flat surface have a rectangular poly structure). And a good 
normals means good shading and good reflections. 

• An original GP4 car has about 2200 faces (polygons), so try to model as few polygon as 
possible. It's because if you use a lot of polygons your car will be great (to take an 
screenshot in ZModeler for example) but when you play in the game with your car the 
CPU will have to calculate a lot of polygons and the frame rate will decrease.  
So think what parts of the car need more polygons and what less, and try to save as 
polygons as possible 

• Remember that the basis of our work are the photos of the car, therefore we need a 
good photos to make a good a realistic car. 
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• To model surfaces in an easy way, begin making a flat surface and then extrude (add 
the 3rd dimension). It's the process used to make the front wing. 

• Remember that we have to make only a half car, the other half is made by mirroring. 

 

Building a GP4 car tutorial  Vicente Martí Centelles 



Building a GP4 car tutorial        |      http://www4.uji.es/~al063357        |        Vicente Martí |        34 

Adjust the normals to get good shading and reflections 
 
First of all, we should remember what is a normal. A normal is a vector (with a length and 
direction). 
Each vertex has a normal, and the most important the normals affect the reflections of the light 
on the car. 
Normal's direction indicates the direction that light will be reflected from a surface, so if you see 
the surface in the direction of the normal all the light will be reflected.  
 
 

 
 
 
But, if you see the surface in other direction different to the direction of the normal the surface 
reflects less light. The more the difference between the directions the less the reflected light. 
You can see it in the following image:  
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The length of the normal indicates how much light is reflected in the direction of the normal. The 
shorter the normal the less the reflection. It's very clear in the image: (left: long normals 
(normalized), right: short normals)  

 
 

 
In this tutorial we will only work with normalized normals (all the normals will have the same 
length). 
We will use the calculation, projection,... methods to make a nice shading to our GP4 car. 

Building a GP4 car tutorial  Vicente Martí Centelles 



Building a GP4 car tutorial        |      http://www4.uji.es/~al063357        |        Vicente Martí |        36 

 
Now we are going to see several examples of surfaces: 
NOTE: we will work in all the tutorial with the normals automatic update and extended mode 
switched off.  

 
 
 
 
 
 
 
A slightly bended surface.  
 
This is a surface with calculated normals (Surface -> Normals -> Calculate). The shading and 
the reflection is good, you can see it in the following images:  
 
This is the surface:  

 
 
 
And this is his shading:  
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But now we are going to detach the surface in two objects and calculate the normals. The 
shading of the resulting surface (the new surface has two objects) is:  
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You can see that the shading isn't good, and it seems that the object have a line in which the 
shading change. 
 
Now, we can see the reflection in this object. The first image is the original object, and you can 
see that have a good reflection and it's smooth and continuous.  

 
 
 
But the detached surface has an ugly reflection and moreover the reflection isn't continuous. 
You can see it in the following image:  

Building a GP4 car tutorial  Vicente Martí Centelles 



Building a GP4 car tutorial        |      http://www4.uji.es/~al063357        |        Vicente Martí |        39 

 
 
 
We can explain it using the normals. In the first image we can see that the vertex of the center 
are single. But in the second image (the detached surface) the vertex are double. 
So the discontinuous shading is due to the double vertex. I have to tell you that different objects 
can't share vertices and it's one of the problems that we will have when we make GP4 cars.  
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A very bended surface.  
 
This is a surface with calculated normals (Surface -> Normals -> Calculate). This surface has a 
sharp edge. We will see the problems of this kind of surfaces:  
This is the surface:  
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This surface has a bad shading, and the edge of the surface isn't good. Moreover the reflections 
aren't good.  

 
 
 
It's because a surface with a sharp edge should be like two different surfaces that reflect the 
light in a different way. Yes, we can do it detaching the two parts of the surface. 
First, let's see a image of the normals of these surface:  
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You can see that the directions of the normals next to the vertex are very different. So to solve 
this we can detach the surfaces. 
To detach the surfaces: Switch to faces level and Select -> Quadr, then select the faces of one 
of the new surfaces:  

 
 
 
Then go to Create -> Objects -> Detach, activate SEL mode and click on the view. Then type 
the name of the new object in the dialog box that will appear.  
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Now you have the surface detached in two objects. If you see the shading of these two objects 
in the 3D view you can see that the shading is the same. But it's because the normals are the 
same (remember that we have switched of the normals automatic update and extended mode 
and we haven't apply any modification to the normals).  

 
 
 
So now we can unite the two detached objects in one. To do this select the two objects (in 
objects level), then go to Create -> Objects -> UniteSelect and click on the view. Write the name 
of the new object in the dialog box that will appear and now you have an object with double 
vertex (this is the name of this process: the double vertex method). 
 
But to get the correct reflection now we have to calculate the normals. Go to Surface -> Normals 
-> Calculate and in objects level click on the object, now in 3D view you will see this:  
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Now we have a sharped edge in 3D view, and it seems that the surface has two independent 
surfaces that reflect the light in a different way. It's because in the edge there are double vertex  

 
 

 
And the surface on the right (vertical) and the surface on the left (horizontal) have a different set 
of normals because they don't share any vertex an then the surface with double vertex has a 
sharped vertex. 
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So double vertex are good if we want to make two independent surfaces with a sharped edge 
and a discontinuously shading. 
 
We can see that the double vertex surfaces has a discontinuous reflection: 
 
Normal surface:  

 
 
 
Double vertex surface:  

 
 
 
To finish whit this surface we can see the normals in the 3D view: Normal surface:  
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Double vertex surface:  
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Now we know how to solve the problem of sharped edges, but we want a sharped edges with a 
continuous shading and reflection we have to increase the number of polygons in the bended 
area (without using the double vertex method),and then the edge will be rounded. You can see 
it in the photos:  
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To conclude this part of the tutorial, if you want a surface with continuous shading and reflection 
don't use double vertex. But if this surface belong to two or more objects then you have to make 
first one object calculate the normals and then detach it in the new objects and don't calculate 
the normals, this is very important because if you calculate the normals the shading and the 
reflection will become a mess with discontinuous shading and the reflection. For example we 
will use these advice when we made the body of the F1 car for GP4 (remember that a GP4 car 
has a lot of different objects).  
 
 
 
 
 
The front wing of the GP4 car.  
 
I create the front wing but I don’t use double vertex to make it, so the shading and the reflection 
is awful. You can see that it's due to the normals that are oriented in a lot of directions.  
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To solve this I detached the upper part of the wing and then unite the two resultant parts and 
then calculate the normals. The result is:  
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You can see that the normals are now ok, all (more or less) in the same direction. When we 
create the other part of the wing we can see that the shading and the reflection is OK.  

 
 
 
Another way is use the projection tool (using as a basis of our work the wing with the double 
vertex). To do this select the upper surface of the wing , place the axis like in the image (the 
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axis is the grey X), activate the SEL mode and then select Surface -> Normals -> Projection and 
click on the Top view. Your normals will have a good appearance in the 3D view. And the 
shading and the reflection will be good.  

 
 

 
The differences between the calculate and the projection methods are shown in the next image:  

 
 

 
 
So it's your decision to use the calculate or the projection method to adjust the normals.  
 
 
 
 
The body of the GP4 car.  
 
In the following image we can see the problem of the different objects in a gp4 car. To solve this 
we have to unite all the body of the car, then unite the double vertex, calculate the normals and 
finally detach the car body in different objects without calculate the normals after detach the 
body in different objects. So we will get a car with continuous shading and continuous reflection.  
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After doing this we will get the correct normals and reflection:  
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To unite the double vertex, follow the following steps:  
 
* Switch to vertices level.  
* Switch MUL button  
* Switch SEL button  
* Select -> Single  
* Create Objects -> Unite select  
 
Then right click to unite the near vertex (the double vertex) and after that left click to unite the 
selected vertex (then we will have only one vertex and therefore one normal). 
 
After unite all the double vertex switch to objects level and calculate the normals, and finally 
detach the car body in different objects.  
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Mapping the car 
 

Mapping Section  
 
In this part of the tutorial is explained how to map our car.  
In this tutorial is explained a method to map the car faster using a template with some polygons.  
 
Let's see the steps to map the car:  
 
1. Make two screen shoots of the car like this: (one from top view, and the other from side 
view):  

 
Side view  
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Top view  

 
 
2. Put the different parts of the car that you are going to map in the material (the texture, that 
have a size of 1024x 1024 pixels). For example I map the sidepods, the nose and the engine on 
the first tga. You can see it in the next image:  
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Filling the texture with some parts of the screenshots  

 
 
We will do the same for the 2nd material, its to say map the side of the nose cone, the front 
wing...  
 
Finally we can use a similar way to prepare the 3rd material, that we will use to map some little 
parts of the car, like car numbers, little wings...  
In the following images you can see that in the 3rd material I have put a lot of squares. It's to 
map the small details of the car. In this way it's very simple to map the details. 
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We will use these squares to map the different parts of the car. The following image shows it:  
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3. Now, in the tga1 and tga2 make some polygons whit different colors to differentiate the 
different parts of the car (using as reference the different parts of the car that we have copied 
and pasted in the second step). These polygons will be our reference when we map the car in 
ZModeler.  
You can use any kind of polygons that adjust at the piece of the car that you are going to map.  

 
 
 
4. Start to map the car in ZModeler (a good tutorial is the Mapping cars for GP4 by 
Auradrummer, you can download it on gpxcarpainting). 
 
First of all I have to tell you that you have to map faces, so we will work on faces level. 
So to map a group of faces, select the faces on faces level (if these faces belongs to different 
objects, remember the ZModeler section of this tutorial that says that to select faces or vertices 
of different objects you have to select the desired objects on objects level, then activate SEL 
mode and switch to faces or vertices level, click on the selection and now you can select the 
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desired vertices or faces.) and activate SEL mode. 
 
The next step is assign a material to our selected faces (remember to activate SEL mode), so 
go to the material editor and assign the material by clicking on the Assign to Selection button.  

 
 
 
After that, you have to assign UV to your selected faces (remember to activate SEL mode). To 
do this, go to Surface -> Mapping -> AssignUV and click on the desired view. 
Remember also that if you want to remap a mapped area first you have to delete the current UV 
mapping of the desired faces. To do this: select the faces on faces level go to Surface -> 
Mapping -> ResetUV (remember to activate SEL mode) and click on the selection. 
The next step is assign UV to the selected faces as usual.  
 
Now you can see in the UVMapper view the map of your selected faces. 
 
Remember that to scale it you should use the numeric box #1. Put in this box the number that 
you want to reduce the size of the texture. The best is reduce the 60% (thanks to Bojan 
Tarticchio to tell it to me). So put 60 in this box and drag with the mouse as usual, it'll scale 
down exactly 60% in steps. Reduce all the mapped objects to 60% using this method.  
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The following image shows the process of map a piece of the car: select a group of faces, map 
the faces (by clicking on the top view), scale the mapped area with numeric box #1 and finally 
see in 3D view the mapped area on the car. 
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5. You can see immediately the parts that are mapped because they are painted in different 
colors.  
 
6. Finally, we are going to show all mapped areas with each material (you can read also the 
tutorial How to find out the mapping of a gp4 car by Max Downforce, you can find it on 
gpxcarpainting. 
 
To show the mapping of the car:  

• Select all the object of the car in objects level.  
• Switch on the SEL mode and go to faces level, right click on the car.  
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• Go to Select ->By Material and select the material that you want to get the mapping, for 
example the vte_1.tga. You will see that the parts of the car that belong to this material 
are selected.  

• Now, go to Surface -> Mapping -> AssignUV (You should know that if you AssingUV to 
a face that is already mapped, ZModeler doesn't assign a new UV, it just show the 
current UV in the UVMapper.)  

• Finally go to the UVMapper view and you will see the UVMapping of your selected 
material:  

 

 
 
To finish we have to make a hi-res screenshoot of the wireframe in order to paint the 
car. 
To make the screenshoot, first make the UVMapper in full view by pressing "f" on your 
keyboard. Then make the UVmapped area as big as you can. Take an screenshot. Go 
to your favourite paint program and paste the screenshot. With the rectangular 
seleccting tool select the inner area of the UVMapped area (I'mean, that you have not 
to select the grey line). 
With the magic eraser tool and with out antialiasing delete all the background but not 
the wireframe. Change the image size to 1024x1024. Finally paint four little withe pixels 
at the corners of the image (it's to avoid problems if you copy and paste the image, 
remember that when you select a image with some transparencies, photoshop 
automatically adjust the selection to the painted area) and save it. 
Congratulations, you have made the first steep to make a good template to paint the 
car. 
 
On point 13 it's explained how to make a nice template.  
 
7. If when you find out the mapping of the car you see that is incorrect (for example one 
surface is in a brong place), no worry, you can solve it.  
Let's see how to solve it, in the following image we can see that the engine surface is 
displaced. 
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To solve this, switch to vertex level and select all the vertex of these surface: 

 

 
 
Now, pres the SEL button on to activate the multiple selection and Modify -> Move. 
Then place the object on the desired polygon: finally you will have the correct mapping:  
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Moreover you can do other things when you have selected all the vertex of a surface: 
scale it, rotate, mirror, reorient... So if we made a mistake when we map the car there is 
no problem because we can solve it using the method that I explained in this point.  
 
8. Sometimes is good to write something when in the texture that we are mapping. 
Then you can see if you are mapping in the correct position or not. For example the 
engine. The image is self explanatory. 
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You can use any kind of polygons that adjust at the piece of the car that you are going 
to map.  
 
9. Another surfaces like the suspensions, the inferior part of the car... are mapped whit 
carbone fribre. To map these we are going to use a method called Tile textures. We are 
going to use a material that is all black with a grey lines.  
Select the surfaces that you would map with carbone fibre,  
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then assign the material to the selection and go to Surface -> Mapping -> AsingUV and 
clic on the view that the surfaces are more visible (for example to map the bottom of the 
car click in the top view, or to map the rear fins click on the right or left view). 
Then in the UV Mapper view you will see the surfaces that you had selected, now make 
them larger with the scale tool (no matter if the objects are outside of the texture), you 
will see something like this:  
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Finally in the 3D view you will see:  
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Now you can scale the surface mapped more or less and you will see that the gray lines 
are closer or they are farther. So you need to experiment and make the size of the 
mapped area that make in 3D view a better presentation. 
Finally do the same for all the surfaces that have the texture carbone fibre.  
 
Another and very useful mapping method to map carbon fibre parts of the car 
(thanks to Bojan Tarticchio to tell this method to us on gpxcarpainting forum.) 
 
First of all make a pattern on your texture with black and gray lines (1 pixel with every 
line) and very wide (about 1024 pixels).  
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Now select the part of the car that you will assign the carbone fibre texture, assign the 
material and UV.  

Building a GP4 car tutorial  Vicente Martí Centelles 



Building a GP4 car tutorial        |      http://www4.uji.es/~al063357        |        Vicente Martí |        71 

 
 

 

 
 
Scale the mapped object to 40% by entering 60 on numeric box#1.  

 
 

 

 
 
Place axis ( X ) on the center of the front wing on the UVMapper view by putting over it 
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the mouse and clicking on the keyboard " . ". Now, rotate the object 45º using numeric 
bar#1.  

 
 

 

 
 
Move the object to the center of the black part of the texture.  

 
 

 

 
 
Finally, place axis ( X ) on the center of the front wing on the UVMapper view. 
Scale in vertical axis (select the V axis mode) and scale to fit it perfectly on the texture:  
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Finally the result is a nice mapped part of the car wiht a good carbone fibre texture:  

 
 

 

 
 
This method is very useful because we don't use much space on the texture and we 
don't need to add a new texture for the carbone fibre.  

10. The next step is do the same for all the car, it's to say finish to map all the car.  
 
 
11. To map more easily you con copy in a paper with a pen the polygons that you have 
made in the 3r step. And now you can with a pen draw the parts of the car that you are 
mapping on the texture and write the name in order to not have problems later (for 
example if we don't draw the mapped parts of the car we can map in the same polygon 
two parts of the car and this is a problem that can be solve it by writing the mapped 
parts in a paper with a pen). 
 
12. The final step it's map the numbers of the car2. To do this save to copies of your 
car: car1 and car2. Now remap the numbers on the car2 and save the changes. So in 
this final step we have two cars: car1 and car2. 
 
13. I will explain the basic steps to create o good template. (the explanation is to 
adobe photoshop, but to other programs like the gimp, paint shop pro... is the same, but 
the tools are located in different places). 
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First of all we have the wireframe in our texture (to get the wireframe of the texture see 
point 6) , it's something like this:  

 

 
 
Now paint the exterior part of the wireframe of your tga in a color that you won't use for 
the car, for example this light green.  

 

 
 
After that select with Magic Wand Tool the exterior part of the wireframe of your tga.  
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The second step is create a new layer with the selection, to do this: right click and 
select Layer via cut in the menu that will appear.  

 

 
 
Go to the new layer and select the green part, now invert the selection in order to select 
the surfaces of the car (Right click and select Select inverse in the meny that will 
appear).  
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Now expand the selection to avoid some problems. For example 3 pixels.  

 

 

 

 
 
The final step is paint the surfaces of the car with the desired color, it's to say, paint the 
selection. I have paint it blue. 
The result is a nice template:  
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And doing the same for all the textures the result is a nice template.  
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The next step is paint the car using this template. Remember to add some texture 
shading, car lines...  
 
 
 
By the way, to get a very precise template you can use a ZModeler plug-ins that 
allows you to export the template in eps format. And it's very precise. 
You can download it on: ZModeler plug-ins  
Hope that this can help you.  
 
 
NOTE: map lod 4  
Remember to map the car lod_4: 
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This shape is very low resolution, to map it only map the correct color on the car: the 
color of the nose, the front wing, the rear wing, the sidepods... It's to see the car in the 
mirrors (you can see the lod_4 in the mirrors). So remember to remap the lod_4 and 
change the name of the materials: use the same materials as in the lod_0 (you can use 
less materials for example VTE_1.TGA and VTE_2.TGA, but the same name for the 
used materials). 
 
I always map the lod 4 when the car is finished. You can see in the next image that the 
map is awful, and the car_lod_4 needs to be remaped:  

 
 

 

 
 
For example I will explain how to map the front wing. Select the front wing (on faces 
level), activate SEL mode, go to surface -> mapping -> Reset UV, and then go to 
surface -> mapping -> Assign UV and click on the top view. Then you will see:  
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The next steep is adjust the mapping at the texture. The following image shows this:  

 
 

 

 
 
And on 3D view you can see the result of our map-change:  

 
 

 

 
 
If we remap all the car (it takes a few time) you can get a nice low-res car:  
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It's to say, we will see the correct colors of our car in the mirrors.  
 
 
 
Some mapings tips  
First of all thanks to Bojan Tarticchio to tell this method to us on gpxcarpainting forum. 
 
This method is very useful for contiguous pieces on our car, it's to say, for the car body 
parts. You don't need to make this for wings and other parts of the car. 
 
To apply this method, first select a piece of our car, assign a material and assign UV. 
Now Scale it to 40% (you must write 60 on the numeric box#1):  
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Finally move this object to the center of the mapping area.  
 
Do the same for the other parts of the car. 
But, for example some surfaces need to be rotated 90º. To make this precise rotation 
use the numeric box#1, and move it to the right of the maping area:  

 
 

 

 
 
Doing the same for the other part of the car, and moving it to the left of the mapping 
area we have all the parts of the car mapped. To see all the parts of this material 
mapped, select all the objects of the car, activate SEL mode, switch to faces level, go to 
select by material and select the material that you have assigned at the mapped parts 
of the car. Finally go to Surface -> Mapping -> Assign UV and click in any view. You will 
see all the mapped parts of this material in the UVMapper view (Note that when you 
select a mapped face and assign UV, you won't delete the previous mapping, you just 
will see the previous mapping in the UVMapper view.) 
It's to say, we will see in UVMapper view:  
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Now switch to vertex level, activate SEL mode and go to Select ->Quad. Move the 
select vertices (all object) to fill all the texture to left less spaces you can.  

 
 

 

 
 
Selecting the other parts and moving it we obtain a good maped texture. 
The next steep is draw a horizontal line (1 pixel width and non-antialiased), this line is a 
marker.  
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The last steep is to align the marker in 3D view by moving the mapped parts (left and 
right) on the UVMapper view. So select one mapped part (switch to vertex level, 
activate SEL mode and go to Select ->Quad) and move the select vertices (all object)) 
to fit it perfectly in 3D view.  
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Finally we can paint some horizontal lines on the nose cone, and we can see on 3d 
view that they fit perfecly.  
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About the materials in a gp4 car  
Original materials in a original GP4 car  
When you import a GP4 car in ZModeler, in the material editor you can see (for 
examples in the original Benetton):  
 
COCKPIT_DAMAGE.TGA  
CARLIGHTMAPCH2.TGA  
CARLIGHTMAPCH3.TGA  
BENETTON_1.TGA  
BENETTON_2.TGA  
BENETTON_3.TGA  
 
 
Making changes to these materials 
You can change the names of BENETTON_1.TGA to VTE_1.TGA, BENETTON_2.TGA 
to VTE_2.TGA, BENETTON_3.TGA to VTE_3.TGA for example.  
Then you can use the car for several slots in GP4. First make sure that your name isn't 
used by another car.  
 
Moreover, the textures:CARLIGHTMAPCH2.TGA and CARLIGHTMAPCH3.TGA are 
very small, they are used by GP4 but if you delete these when you export the car they 
will be created. They aren't assigned to any part of the car.  
 
You can use any material to any object when you map the GP4 car in ZModeler. And, 
moreover you can add some new materials as for example VTECARPARTS.TGA to 
increase the detail level in the car and for example the material used to map the 
carbone fibre parts on the car.  
 
In the original GP4 car, the materials z_cockpit_right_mirror and z_cockpit_left_mirror 
are assigned to the material COCKPIT_DAMAGE.TGA to get reflections when you 
import the car in the game you need to assign these material to these objects, if you 
don't do this the mirrors won't reflect nothing.  
The mapping of these two objects are shown in the image:  
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Moreover, the z_cockpit_visor must be mapped in the material 
COCKPIT_DAMAGE.TGA because this object has a transparency in the game, the 
following image shows it:  
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The other z-object is z_cockpit_interior, but you can map it in the BENETTON_1.TGA or 
other material, it doesn't matter.  
 
I think that is a goog method because when you modify a part of the car, you will have 
the necessary space to map the new part. 
But in the other hand, you will leave some space without any use.  
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Paint the car 
Paint the car ( Texture Shading, Car body lines and Screws, Logos, Cockpit, Helmet, 
Pitcrew )  
 
 

First of all you need the template, we have made this in the final step at the mapping section. 
(you can read a full description on the tutorial Quick Guide to find out mapping gp4 by Max 
Downforce.) 
Now paint these textures, add logos, add a texture shading... and finally add an alpha layer (an 
alpha layer in gp4 means how is the reflection of the light: white -> all light is reflected and black 
-> no light is reflected). The best way to make an alpha layer is make the entire alpha layer gray 
and then add some black in the zones that shouldn't reflect the light.  

First of all I have painted the background of the car of color blue:  

 
 

 

The next step is add some texture shading (dark shading and highlights), car body lines and 
screws. 
Texture shading, car body lines and screws make the car more realistic and the look of the car 
improves a lot with these little modifications at the texture of the car. 

• Texture shading   
 
Texture shading makes the car better and improves a lot the 3D shading of our car. 
Let's see how to make texture shading for the barge board: 

 

 

 
First of all make a new layer and name it as dark_shading. Select with the polygonal-
lasso the section of the texture that you want to add the shading. 
The next steep is paint the interior of this selected part with the Brush Tool with medium 
opacity in color black. 
After that, with the Eraser Tool and with a very low opacity erase the parts of the dark-
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painted area to get the correct shading. 
Now make the same for all the parts of the texture that need dark-texture shading. 
Finally, when you have finished to paint all the shadings on the dark_shading layer, aply 
the Blur Tool to fix some imperfections on the shadings. 
 
The result for my barge board is:  

 

 

 

 

 
You can make also highlights in the same way, but now create a new layer and name it 
as light_shading. Select with the polygonal-lasso the section of the texture that you 
want to add the shading. 
The next steep is paint the interior of this selected part with the Brush Tool with medium 
opacity in color white. 
After that, with the Eraser Tool and with a very low opacity erase the parts of the light-
painted area. 
Now make the same for all the parts of the texture that need light-texture shading. 
Finally, when you have finished to paint all the shadings on the light_shading layer, aply 
the Blur Tool to fix some imperfections on the highlights . 
 
You can see the result of the highlights on the nose cone of my movistar car:  
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• Car body lines and screws  
 
These lines improve a lot the look of your car and make it more realistic. 
These lines are the lines that split the different parts of the car, so take in mind the 
different parts of the car. 
 
To create this lines first create a new layer for dark body-lines and screws. We will 
create the lines in color black. 
These lines have 2 pixel width (anti-aliased), and the screws have about 5 pixels 
forming a cross (anti-aliased too). I've used anti-aliased to make the curves of the body-
line smooth. 
The next image shows some dark body-lines:  
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Now, create a new layer for light body-lines and screws, the lines will be white. 
These lines have 1 pixel width (anti-aliased), and the screws have about 5 pixels 
forming a cross (anti-aliased too). I've used anti-aliased to make the curves of the body-
line smooth. 
And you have to make these lines in the inner or the outer part with respect to the dark 
body-lines and screws created in the previous step.  
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Finally we have to adjust the opacity and the brightness of the two layers (dark body-
lines and screwslight / body-lines and screws). 
The purpose of this step is to get a good 3D effect on our texture. 
Making some fine adjustments the result is:  
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•  Logos  
 
In this section is explained how to add some logos to our car. 
To start we have to get some logos that we can found searching en google ( www.google.com ) 
or in a web page, where we can get lot of logos of all brands of the world: 
www.brandsoftheworld.com .  
 
Now, we have to paste the logos over the template, but we must do it in a separate layer, is to 
say, in a different layer from the layer of the background color. 
 
Another piece of advice is add some shading around the logos to make the logos alive and get 
and impacting and realistic look to our car. 
 
The next images show the textures of my movistar f1 car, in these images you can see all the 
things said previously (they are self explanatory): 
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And you can see the result in the next images:  
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Paint the cockpit  

We need to paint the cockpit of our car in order to see the correct colours on the on-board 
camera in gp4. 
It's easy to paint the cockpit if you get a template first of all. For example I will paint the Original 
Cockpit Template by Nico from gpxcarpainting. You can read the readme file of this template 
that explains how to use it. 
First of all I have to tell you that the cockpit has one texture only (tex file): cp_myteam.tex . 
So we only need to modify this file. 

 

 

cockpit template  

 

movistar cockpit  
 
After paint the template we can see it in 3D view of ZModeler:  
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movistar cockpit, 3D view  

To finish our work, add and alpha layer, invert the textures and save the textures in tga 
format(32 bits and RLE encoded (RLE encoded is optional, but is better because the tga have 
less size)): cp_myteam.tga 
Make a back-up of your cars.wad 
Create the tex files with TexResizer (cp_myteam.tex)and update your cars.wad with 
WadUpdater (Open Wadupdater, select the cp_myteam.tex and the cars.wad. Then click on 
UpdateWad and automatically the cp_myteam.tex will be updated in your cars.wad. 
 
With TeamEditor you can change the name of the slot and this affects to the name of the 
carshape (car_myteam_car1_lod0.gp4 ...) and for the cockpit name (cp_myteam.tex). So you 
have to use the name of the slot name of your team (it's to say the same name as your 
carshape).  
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movistar cockpit in game  
 

 
Paint the helmet  
 
You can also paint the helmet of the driver of your car, you can edit the tex files in your 
cars.wad. They are: 

Team 1  driver1_1.tex, driver1_2.tex for driver 1. 
driver2_1.tex, driver2_2.tex for driver 2.  

Team 2  driver3_1.tex, driver3_2.tex for driver 3. 
driver4_1.tex, driver4_2.tex for driver 4.  

Team 3  driver5_1.tex, driver5_2.tex for driver 5. 
driver6_1.tex, driver6_2.tex for driver 6.  

Team 4  driver7_1.tex, driver7_2.tex for driver 7. 
driver8_1.tex, driver8_2.tex for driver 8.  

Team 5  driver9_1.tex, driver9_2.tex for driver 9. 
driver10_1.tex, driver10_2.tex for driver 10.  

Team 6  driver11_1.tex, driver11_2.tex for driver 11. 
driver12_1.tex, driver12_2.tex for driver 12.  

Team 7  driver14_1.tex, driver14_2.tex for driver 14. 
driver15_1.tex, driver15_2.tex for driver 15.  

Team 8  driver16_1.tex, driver16_2.tex for driver 16. 
driver17_1.tex, driver17_2.tex for driver 17.  

Team 9  driver18_1.tex, driver18_2.tex for driver 18. 
driver19_1.tex, driver19_2.tex for driver 19.  

Team 10  driver20_1.tex, driver20_2.tex for driver 20. 
driver21_1.tex, driver21_2.tex for driver 21.  

Team 11  driver22_1.tex, driver22_2.tex for driver 22. 
driver23_1.tex, driver23_2.tex for driver 23.  
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But you have to modify the files in the folder: GP4/cars, these tex files are: 

• driver9_1.tex, driver9_2.tex 
• driver10_1.tex, driver10_2.tex 
• driver21_1.tex, driver21_2.tex 

(don't ask me why these tex files are here, but if you don't replace it in this folder, you will see 
an incorrect textures in the game.)  

Let`s see an example of a helmet, the shape of the helmet is: 

 

 

Like in the car, we now are going to paint the helmet using the template. 
It's easiest to paint the helmet as the car. You can see it in the next tga files for the helmet 
(driverX_1.tex, driverX_2.tex):  

 

 
driverX_1.tex  

 

 
driverX_2.tex  
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Finally we can see the result of our work on the 3D view of ZModeler. The next image shows my 
helmet for the movistar F1 car:  

 

 
Helmet for the movistar F1 car  

To finish our work, add and alpha layer and save the textures in tga format(32 bits and RLE 
encoded (RLE encoded is optional, but is better because the tga have less size)): driverX_1.tga 
and driverX_2.tga. 
Note that you have not to invert the textures. Moreover I have to tell you that invert the textures 
depends on the template and the .z3d file to see the helmet in ZModeler. In some templates 
and .z3d files you don't need to flip vetically the textures but in others not. So, don't worry about 
this, if the texutre is incorrect in gp4 (flip vertically), just flip vertically the textures and you will 
solve your problem.  
Make a back-up of your cars.wad 
Create the tex files with TexResizer (driverX_1.tex and driverX_2.tex)and update your cars.wad 
with WadUpdater (Open Wadupdater, select the driverX_1.tex and the cars.wad. Then click on 
UpdateWad and automatically the driverX_1.tex will be updated in your cars.wad. Do the same 
for the driverX_2.tex). 
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Helmet in game  
 

Helmet in game  
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Helmet in game  

 
Paint the pitcrew  

Finally we will paint the pitcrew. 
The textures for the pitcrew are located in the anim.wad. The tex files for the engineer are 
located in the folder \animationdata\qualifying\skins and the name of the tex files are 
engin_myteam.tex. 
The tex files for the pitcrew are located in the folder \animationdata\race\skins and the name of 
the tex files are pitcrew_myteam.tex. 

Now our work is modify these textures, but we will use the Pitcrews templates by 
MaxDownforce and ChaosF1 from gpxcarpainting. 
The textures that we have to modify are:  

 

Pitcrew template, file: 
pitcrew_myteam.tex  

 

Engineers template, file: 
engin_myteam.tex  

Finally painting the background of this template and adding some logos we have a good 
pitcrews and engineers for our F1 team:  
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Pitcrew template, file: 
pitcrew_myteam.tex  

 

Engineers template, file: 
engin_myteam.tex  

 

To finish our work, add and alpha layer and save the textures in tga format(256pixels X 
256pixels) (32 bits and RLE encoded (RLE encoded is optional, but is better because the tga 
have less size)): pitcrew.tga and engin.tga. 
Note that you have not to invert the textures. Make a back-up of your anim.wad 
Create the tex files with TexResizer (pitcrew.tex and engin.tex)and update your anim.wad with 
WadUpdater (Open Wadupdater, select the pitcrew_myteam.tex and the anim.wad. Then click 
on UpdateWad and automatically the pitcrew_myteam.tex will be updated in your anim.wad. Do 
the same for the engin_myteam.tex). 
 
Moreover, you have to use the original slot name for the pitcrew_myteam.tex and 
engin_myteam.tex, its to say if your team is in the slot 11 you have to use the prost name for 
myteam. 
I have tell you this because with TeamEditor you can change the name of the slot and this 
affects to the name of the carshape (car_myteam_car1_lod0.gp4 ...) and for the cockpit name 
(cp_myteam.tex). And the name of the helmets and the pitcrew aren't changed. So you must 
use the original team names for the pitcrews and engineers and original numbers for the 
helmets. 
 
The original slots names are:  

• ferrari -> slot1  
• mclaren -> slot2  
• williams -> slot3  
• benetton -> slot4  
• bar -> slot5  
• jordan -> slot6  
• arrows -> slot7  
• sauber -> slot8  
• jaguar -> slot9  
• minardi -> slot10  
• prost -> slot11  
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Pitcrew in game  
 

Pitcrew in game  
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Pitcrew in game  
 

Engineers in game  
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Engineers in game  
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Get the car in game 
 
 
Get the car in game  
 
The names of the files needed for a gp4 car are:  
 

Car 1  

car_myteam_car1_lod_0.gp4 
car_myteam_car1_lod_1.gp4 
car_myteam_car1_lod_2.gp4 
car_myteam_car1_lod_3.gp4 
car_myteam_car1_lod_4.gp4  

Car 2  

car_myteam_car2_lod_0.gp4 
car_myteam_car2_lod_1.gp4 
car_myteam_car2_lod_2.gp4 
car_myteam_car2_lod_3.gp4 
car_myteam_car2_lod_4.gp4  

 
* Some teams have a file: car_myteam_car(1 or 2)_lod_35.gp4, if you are going to edit the car 
of one of these teams, delete this file (don't ask me why). 
 
The difference between the diferente files is that the lod_0 is the most detailed and the lod_4 
the less detailed. You see the lod_0 when the car is in a short distance and the lod_4 when the 
car is far like in the mirrors.  
 
The difference between the car1 and car2 is the mapping of the numbers (remember the final 
step of the mapping section, we have saved the car as car1 and car2, then we have mapped 
the number in the car2 in a different place with regard to the numbers of the car1).  
 
So now the process is simple, first of all check the order of the 28 objects. Second export the 
car1.z3d to car_myteam_car1_lod_0.gp4, and the lod_0 for car1 is made. To make the lod_1, 
lod_2 and lod_3, delete the z-objects from the car1.z3d (z_cockpit_insert, 
z_cockpit_left_mirror,z_cockpit_right_mirror, z_cockpit_visor), export this file as: 
car_myteam_car1_lod_1.gp4, car_myteam_car1_lod_2.gp4, car_myteam_car1_lod_3.gp4. 
 
Do the same for the car2.z3d 
Remember the car_lod_4 that we have remapped, export this shape and save it as: 
car_myteam_car1_lod_4.gp4 and car_myteam_car2_lod_4.gp4 
 
IMPORTANT: 
To export the car you have to load all the textures (in the material editor), in this way you will 
see the textures in 3D view. If you don't do this the textures are exported improperly. 
 
I've put the word myteam but you have to change it depending in what slot you are going to put 
the car:  

• ferrari -> slot1  
• mclaren -> slot2  
• williams -> slot3  
• benetton -> slot4  
• bar -> slot5  
• jordan -> slot6  
• arrows -> slot7  
• sauber -> slot8  
• jaguar -> slot9  
• minardi -> slot10  
• prost -> slot11  
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Moreover, I have to tell you that if you want you can change the name os the slot with 
TeamEditor, it's to say you can use any name for your slot. For example you can change the 
name of slot 11 to vicente and then name the gp4 files as: car_vicente_car1_lod_0.gp4, 
car_vicente_car1_lod_1.gp4 ... 
 
The next image shows the TeamEditor. You can load all available carshapes in your cars.wad. 
So when I update my cars.wad with the gp4 files car_vicente_car1_lod_0.gp4 ... I can choose 
all available carshapes in the cars.wad. Very simply.  

 
 

 
 
 
Now the shapes are ready to get back in GP4. Remember that you can use your shape for any 
slot because you have named the textures VTE_1.TGA, VTE_2.TGA and VTE_3.TGA or a 
similar name (this name must be different form ferrari, maclaren, williams, benetton, bar, jordan, 
arrows, sauber, jaguar, minardi and prost). Then the car will search the textures named 
VTE_1.TEX, VTE_2.TEX and VTE_3.TEX and doesn't matter the slot of the car. 

Now you need to save the textures of the car as TEX. We can use gp4-master (read the 
carpainting tutorial by Thijis (a.k.a. Knight)) or if you want you can use TexResizer 
(www.realgpx.com). It’s very simple to use, just open an existent tex file, set the with and height 
as 1024. Then right click over the big picture and select load from tga. Then search your tga. 
After that click on downsample and save .tex file.  
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Do the same for all tex files. Remember that the hi_mycar.tex are 1024x1024 and the mycar.tex 
are 512 x512. And note that you have to flip the tga vertically before loading in texresizer. The 
result is  

 

And after that you have created your tex files for your car.  

With the 10 gp4 files and the TEX files update your cars.wad (read the carpainting tutorial by 
Thijis (a.k.a. Knight)), the car is installed in the game 
 
Finally we need to adjust the position of the steering wheel and the helmet, and change the 
rims' color. To do this use Team Editor (dowload in www.realgpx.com) 

Or if you want you can use WadUpdater (www.realgpx.com)  
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First of all make a backup of your cars.wad, then to get the car in your cars.wad, put the 10 gp4 
files and the TEX files in a folder, then select it with the button Select a Folder. After that select 
your cars.wad in the GP4 folder and click over Update wad. Your wad will be updated in few 
seconds.  

 
 
Finally, we can adjust the position of the steering wheel and the helmet, and change the rims' 
color. To do this use Team Editor (download in www.realgpx.com) 
To make these changes, you only have to run Team Editor and then change the coordinates of 
the helmet and the steering wheel and see in 3D view is they are in the correct place. To 
change the color of the rims, double click in the box color of the rim and change the color. 
Moreover you can change the brand of the tyres (michelin or bridgestone) with this program. 
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Change car power, downforce, max RPM, mass...  
 
To finish our car we must change some of the physics of our car with GP4 Physics Editor v1.03 
by Aubrey Windle. 
You can download it on www.grandprixgames.org or any gp4 website. 
 
The next images are self-explanatory, and show all you can modify of the GP4 car phisics:  
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My advice to use GP4 Physics Editor v1.03 is: unzip the gp4phys.zip in a folder called gp4phys, 
then copy your GP4.exe from your GP4 main folder (note that GP4 Physics Editor v1.03 only 
works with the decrypted v1.02 version of gp4.exe that is available on various websites, the 
gp4.exe v1.02 is the version of the official patch 9.6). 
Now open the GP4Phys.exe and you will see the GP4 Physics Editor v1.03. Then make some 
changes at the values. (You can see a good explanation with the help of the GP4 Physics 
Editor). 
The best is change the Human Race Power and Human Qualy Power and the Max RPM, and 
you will see that your car is faster. 
 
Finally save your current Physics data to a .gp3 file that you can load in GPxPatch, for example 
mycar.gp3. Now go to your GP4/gpxdata/ folder and copy this file, then run GPxPathc and go to 
GPxPatch -> GPxSet and load your GP4/gpxdata/mycar.gp3 and all is done. Just run GPxPatch 
and drive with your new physics with you car, you will see that your car is faster (if you have 
increased the car power), it's to say, your lap times will decrease. 
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By the way, you can edit directily your GP4/gp4.exe and you don't need to use GPxPath, but I 
prefer to don't edit the GP4/gp4.exe to avoid problems. 
 
Moreover you can change some parameters of the car with Team Editor. 
The next images shows that you can change Brand Type, team name and engine name, cars 
power, % of failure, and gears. I have to tell you that if you change the cars power with team 
editor it only affects at the performance of the cars and your car won't be faster and you won't 
improve your lap times. 
 
And on the Drivers section you can change the performace of the drivers and the name of the 
drivers. 

 
 

 
 

Building a GP4 car tutorial  Vicente Martí Centelles 



Building a GP4 car tutorial        |      http://www4.uji.es/~al063357        |        Vicente Martí |        117 

 
 

 
 
 
 
 
Congratulations, you can play with yours spectacular F1 car in GP4. Good race. 
 
Note that I will improve this part of the tutorial in next versions.  

You can see some images of my 1st car that I made for GP4 (I only changed the front wing of 
the original benetton and paint it).  
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Symmary 
 
I'm going to explain the basic steps to make the car:  

• Import the lod_0 of the original gp4 car and save it as car1.z3d 
Import the lod_4 of the original gp4 car and save it as car_lod_4.z3d 

• Modify the car using photos as the basis of our work. Calculate the normals 
• Detach the car in the objects needed for a gp4 car (see the list) and order them in the 

same order as in the list. 
• Map the car (remember to map the lod_4), and change the name of the materials to a 

different name (different of the names of the original gp4 teams). 
• Paint the car. 
• Create the tex files 
• Make the shapes for gp4 exporting them using ZModeler (remember to load all the 

textures before exporting the car). 
• Update your cars.wad with gp4-master or WadUpdater (with the tex and gp4 files 

created before). 
• Change the helmet and steering wheel position,and the rims' color with Team editor. 

Modify the phisics of the car with GP4 Phisics Editor. 
• Congratulations, you have made a gp4 car. Enjoy it. 
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Useful links and tutorials 
 

Useful Tutorials  
• Carpainting guide by Thijis (a.k.a. Knight)  
• Quick Guide to find out Mapping GP4 by Raymond (a.k.a. Max 

Downforce)  
• ZModeler full documentation  
• ZModeler: creating cars from scratch  
• All the tutorials in gpxcarpainting  

 
Useful links  

• gpxcarpainting (http://racing-leagues.com/gpxcarpainting/) 
• ZModeler official site (http://www.zmodeler2.com/) 
• www.grandprixgames.org  
• realgpx (http://www.realgpx.com/) 
• Gp4 tracks by Ricardo Lampert 

(http://ricardolampert.drivingitalia.net/) 
• GPxPatch (http://www.xs4all.nl/~rsdi/) 
• www.f1games.it 
• www.gp4spain.com  
• realgpx (http://www.realgpx.com/) 
• ZModeler plug-ins (http://pedro2.spytech.cz/zmodeler)  
• Logos (http://www.brandsoftheworld.com/) 
• f1-racing (http://f1.racing-live.com/) 
• f1total (http://www.f1total.com/) 
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ChangeLog 
 
 

ChangeLog  
 v1.0 (4/1/2005)  

First release of the tutorial. 
The origin of the tutorial was the result of some post on 
gpxcarpainting forum about mapping and adjust the normals.  

 v1.1 (30/3/2005)  

Added a ZModeler quick guide that explains all that you should 
know about it to build a gp4 car. 
Added a section that explains how to buid the mesh of the car. 
Mapping and normals sections are improved. 
Added some new sections: paint the car, get car in game, summary 
and the most useful links.  

 v1.2 (30/6/2005)  

Added a tip that explains how to order objects by alphabetical order 
usen 3Deditor. 
Improved paint the car section with an example of the movistar F1 
car. 
Improved get car in game section with explanations about how to 
use TexResizer, WadUpdater and TeamEditor. 
Added more links. 
Added Acknowledgment section  

 v1.3 (20/8/2005)  

Finally the tutorial have been trasnlated to Spanish. Added an 
explanation about how to paint cockpit, helmets and pitcrews with 
some examples and lots of photos. 
Some explanations about Texture shading, Car body lines and 
screws. And some examples with lots of photos. 
Added an explanation about how to change the cars power with gp4 
physics editor. 
Added an explanation about how to get car in-out game with 
WadUpdater. 
Improved the Mapping section: improve the explanations about my 
mapping method and added an explanation about how to map the 
car (an explanation for begginers). Added some mapping tips: 
mapping continous surfaces of the car, mapping carbone fibre 
surfaces (thanks to Bojan Tarticchio to tell this method to us) Added 
some tips about the car_lod_4: map this car to see the correct 
colors.  
Corrected some grammar mistakes on the tutorial. And improved 
some explanations in all the tutorial. 
Added a table of ZModeler hot-keys and an explanation about how 
set up hotkeys in the ZModeler section.  
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